Xbox One patch-notes

This is the full version of the patch notes. Version on the console is incomplete.

Please be aware of plot spoilers in the description below!


  • Fixed the issue due to which sometimes it was impossible to save the game.
  • Respec should work fine now.
  • Black screen after the cutscene in Varnhold’s Lot DLC was fixed.
  • Issues that led to broken saves were fixed.
  • If there wasn’t enough space on the console, the saved games could become corrupted. Resolution: fixed. Now a message about insufficient disk space is displayed on Xbox.


  • It was possible to enter the locations that required certain companions even if you had no such companions in your party. Resolution: fixed. If you are stuck in such a location, try loading an autosaved game before entering the area.
  • There were some incorrect ways of exiting the location with the Everblooming Flower in the Other World. Resolution: fixed.
  • Zombies in Vordakai’s Tomb failed to use weapons. Resolution: fixed.
  • It was possible to start a fight with Marquise Immolatia when entering Lostlarn Keep — Upper Reaches. Resolution: fixed.
  • Dallirun Myrnas failed to summon the undead on the Flintrock Grassland. Resolution: fixed.
  • Kassil Aldori was missing on the Flintrock Grassland. Resolution: fixed.
  • You could no longer interact with Astradaemon at Vordakai’s Tomb after talking to him. Resolution: fixed.
  • Now you cannot leave Vordakai’s Tomb until you talked to Maegar Varn.
  • In the Other World area, the teleporting system was greatly improved to prevent characters from being stuck when they use teleportation spells (e.g. Dimension Door).
  • If your main character fell unconscious before your companions when you first met the Technic League, that could lead to gameplay-related issues in the area. Resolution: fixed.
  • Fixed the issues with the characters’ movement in the Stag Lord’s Fort.
  • Fixed the error due to which you could lose control over your party after Tristian’s attack at the Abandoned Keep.
  • It was impossible to enter the Valley of the Dead if Jaethal wasn’t in the party. Resolution: fixed.
  • The characters could sometimes be stuck in the throne room. Resolution: fixed.
  • Fixed the issue with the freezing of Octavia and Regongar’s scene in the tavern.
  • In Jamandi’s mansion and some other areas, weapons sometimes were hanging in the air. Resolution: fixed.
  • The main character was hanging in the air during the dialogue with Kaessi in her house. Resolution: fixed.


  • When you chose a chaotic evil option in the dialogue with Rook at the Ruined Watchtower, it was impossible to get the item necessary to solve the puzzle. Resolution: fixed.
  • Even if one of the tiefling sisters was dead, you could still ask to talk to her in the corresponding dialogue in the capital. That resulted in numerous further issues. Resolution: fixed.
  • The romance dialogue with Tristian started each time the player’s character entered the main square in the Capital. Resolution: fixed.
  • When companions joined the main character, sometimes they were not linked. Resolution: fixed.

Classes & Mechanics

  • Fixed the issues with Nereids’ aura in the game saves.
  • The alchemists could use Fast Bombs as a standard action. Resolution: fixed.
  • The kineticist’s Shroud of Water ability worked incorrectly. Resolution: fixed.
  • Frightened characters couldn’t take actions in their turn in turn-based mode. Resolution: fixed.
  • Characters with the Kinetic Blade ability were unable to attack enemies in turn-based combat if they needed to come closer to their target. Resolution: fixed.
  • Spells that have a line of effect and cone-shaped spells sometimes failed to hit the targets that were standing behind opened doors. Resolution: fixed.
  • Fixed the duration of Gather Power and other effects in turn-based mode.
  • The abilities that used a swift action each round, spent it even if they were disabled. If a swift action was spent, the prediction panel showed that a free-action ability would be used as a standard action. Resolution: fixed.
  • The kinetic knights started the game with 0 gold. Resolution: fixed.
  • The kineticist’s action panel was sometimes displayed incorrectly. Resolution: fixed.


  • Fixed the Necklace of Double Crosses.

User Interfaces

  • Now the effect duration is displayed in rounds in turn-based combat.
  • The page for the Illusion school of magic was empty. Resolution: fixed.
  • Unessential messages are no longer displayed in the combat log during cutscenes at the House at the Edge of Time.
  • Some converted spells were incorrectly displayed on the spell panel. Resolution: fixed.
  • In some cases, hints in the Equipment and Inventory windows were displayed incorrectly. Resolution: fixed.
  • Fixed the issue when Amiri’s fourth weapon slot was locked after Armag broke her sword.
  • Now you can change the order of characters in your group


  • The number of available quicksaves and autosaves was set to 1.
  • Some combat log notifications about spell immunity have been localized.
  • Fixed the issues when the AI missed the turns, especially at low FPS.

As there is no note regarding fixing the crash to dashboard on Saves, move-to-attack stutter costing turn or framefrate issues that often lead to a crash out, can we confirm there are more patches to come please?
I’m not going to sully my experience further by playing until these are done :slight_smile:

1 Like

Shouldn’t this topic remain pinned and the patch notes be what gets unpinned?

Ah from what I’ve read on the ps4 patch this doesn’t fix the save issues or frame rate and game crashes so xbox players dont get your hopes up as u will be left salty.

The Playstation results, have not been promising.

The few questions I am curious about not is this.

1: Which version of the Xbox/PS4 were the patches designed with in mind. When I got my One X games that were buggy before ran smoothly. If this was made with the highest end models in mind then its not good for those below.

2: Do we have to make new games? Some times with major patches on the unity engine you can’t load a save from a previous build and it work. It can actually cause some additional conflicts, in some cases.

3: Are people clearing their caches and reserved space before loading up their games, after the patch? Does it help in this case?

4: Their is a conflict in the Forum patch notes and the on board patch notes with the PS4. Did everything make it through the “screening process” or did DS trim it, or are the patch notes on board inaccurate?

I guess we will see what the stability, and state of the game is tomorrow. If there is still issues or new ones the Developers have to get in front of it NOW, not wait 2 weeks to address the community like last time.

Fingers crossed.

1 Like

I wonder the same, especially about the versions of consoles because I have a regular Xbox One.

As you said: The discrepancy between the patch notes here and the official patch notes after updating suggest that parts of the patch didn’t make it through Sony’s screening process - would fit from what people allegedly experienced for example still having savegame issues.
Could (!) be different on Xbox though.

It is advisable to clear the cach after updating (btw. I only do updates, no gaming anything else), so I definitely gonna do it.

Don’t have that many fingers for this to work … I try my toes too.

1 Like

Not just Sony. In one of the official responses it was said that their patches first go to Deep Silver for screening and approval and then DS forwards it to the Consoles…

1 Like

Right :thinking: - so it is possible that Deep Silver finally made its job. Could be the case that they rejected parts of the patch. Could have been Sony. Thing is, I trust the guys from Sony and Microsoft a bit more on this issue…at least when it comes to the question how their platforms work and handle space. And that’s saying something. I mean, we are talking about Microsoft :wink::sweat_smile:

Additional thought: but if elements of the patch on Xbox where rejected, why did they create thos thread. Okay, it’s copy and paste but still, I would at least now play with open cards (not sure about the English expression here). :thinking::thinking::thinking:
I’m a bit lost at this point.

1 Like

If I am correct to your intent the English expression (at least in American English) is “All your cards on the table.”

I am among the gaming community that does not trust the industry period. I have watched everyone from AAA studios to indy ones not fulfill their promises, lie, redirect blame, refuse to listen to the consumer, and so many other things let alone the way studios sabotage IPs. So i distrust the whole system.

I just really hope Owlcat is different especially since they are handling a Table Top RPG conversion. I have been playing ttrpgs for 32 years so I am extremely passionate about games based on them.

1 Like

Has the Xbox version dropped for anyone yet?

That’s the expression! :slightly_smiling_face: Thanks for helping me out. :+1:

Well, I see what you mean and why. I don’t trust them too. What I wanted to say is that for example Sony knows how its platforms handles savegames, hdd space and RAM better - someone previously noted that Owlcat probably didn’t had in mind that different platforms handle these things, well, differently. And that seems to be the case here?

I really hope they can fix this because I just love these kind of games, I was player and game master for some time (Das Schwarze Auge / The Dark Eye), and I don’t know why but these isometric games with their love to detail appeals to me a bit more than many other fantasy games. Maybe it’s some kind of “Baldur’s Gate” nostalgia. :blush:

1 Like

Still no update on it being out yet?

Downloading now 11.97gb.

Cheers thanks for the heads up, it’s like 10:30 pm over here so hopefully it’ll be ready by the morning but I’m just stoked to be able to play, hopefully we don’t experience this new Varnhold’s lot bug, after they just fixed the last one.

patch download now, 15:30 pm italy

XB1X, no mods.
Respec works! Thank you!

Great job, keep up the good work OwlCat!

Just an FYI… I know there are people who are having trouble with this game, but there are many of us who it works quite well for.

  1. I’ve never had a bad save. I keep 5 manual saves with auto saving off.
  2. My XB1X has never ‘crashed’ or ‘Blue screened’ if you will. I have about 60% free space on it.
  3. Yes when I’m in my city with lots of people moving around it’s slow, but it never crashes.
  4. I don’t get Black screens that don’t go away.

Issues that affect me:

  1. Quick-bar on my created characters gets blanked out sometimes (known issue; have to add the stuff back - takes a minute or 2).
  2. Trying to Heal a character that is more than 3 steps away, the move happens but not the healing spell (known issue; I just have to move to the character first then enact the healing spell).
  3. Moving more than 5 steps to attack an enemy sometimes they don’t make it and stop half-way through (known issue, happens about 10% of the time for the characters I do that with).
  4. ReSpecing - Fixed with this last update. Thank you.

I thought it important to keep perspective for others who are reading all these posts and are thinking of playing the game.

Thank you.


XB1 X too here, and these bugs are exactly the same i have to struggle with. Will wait for another patch but yes, it is actually playable for me. The only thing is that i stopped at the beginning of chapter 2. No crashes, no black screen and some stuterring every 30 seconds in crowded places like the city place. One other thing : i’m french and i’m happy to see that they improved the localisation.

For me the patch resolve one party of my problem (end of the dlc varnhold) but not possible to continue after and not possible to save (Xbox) sorry for my english (french lol)