PS4 patch-notes 01.03

PS4 patch-notes 01.03

Please be aware of plot spoilers in the description below!


  • Fixed some of the issues that led to corrupted save files.
  • Fixed the issue due to which the game sometimes couldn’t be saved at the end of the Varnhold’s Lot campaign.
  • The Fog of War data storage format in the saved games has been changed, thus decreasing the files’ size. Special thanks to our player Hambeard for this idea!
  • It was impossible to close the message box with congratulations on completing the Varnhold’s Lot campaign. Resolution: fixed.
  • Fixed the issue due to which the final boss failed to appear at the end of the Varnhold’s Lot campaign.
  • Fixed the issues with the characters’ movement: at the Capital Square, in the Adamantine Shield Fortress, in the Lostlarn Keep — the Depths.
  • The performance has been slightly improved, namely, when using a large number of long-lasting AoE effects (auras, Cloudkill and so on).
  • When enabled, the ‘Auto interrupt movement’ setting interrupted the attacks and touch spells, especially at a low FPS. Resolution: fixed.
  • When a character had a charged spell and couldn’t reach their target, a turn now ends automatically even if the character still has a touch attack available.
  • Fixed the hints that showed lines of enemies’ and allies’ attacks.


  • Fixed the issue due to which moving from one zone to another with a large party (20+) could result in the game crash.
  • It was impossible to attack Kobold Artist at the troll’s lair. Resolution: fixed.
  • Fixed the issue due to which it was possible to talk to the inquisitor at the Secluded Lodge only once.
  • Fixed Octavia’s position at Oleg’s Trading Post.
  • Fixed the positions of some enemies at the Old Sycamore area.
  • Fixed the looped romance scene with Regongar in the Capital.
  • The joking mite was rescued from under the ground in the Old Sycamore Caves.
  • A rare issue with exiting from some areas has been addressed once again by improving the algorithm that determines the point of switching between locations.

User Interface

  • The UI could sometimes work incorrectly if you opened and closed the spellbook quickly on the spell selection page during the level-up or character generation. Resolution: fixed.
  • If you increased a character’s level and then moved to another location sometimes the class selection page worked incorrectly for another character. Resolution: fixed.


  • Bracers of Armor failed to protect from incorporeal touch attacks. Resolution: fixed. Bracers of Armor now provide a bonus against incorporeal touch attacks.
  • Instead of applying one of the three effects at random, the Black Star starknife applied all three at the same time.


  • The event with Sartayne (Nazrielle’s apprentice and royal advisor) in the throne room worked incorrectly. Resolution: fixed.

Classes & Mechanics

  • Weapons disappeared when standing after knockout. Resolution: fixed.
  • Commands given during the cutscenes played in turn-based mode could be interrupted by the combat logic, which resulted in the cutscene issues. Resolution: fixed.
  • If a character was moving when a cutscene started in turn-based combat, the game could freeze. Resolution: fixed.
  • If you had a lot of mercenaries, the game could freeze for a long time when calculating the kingdom data automatically. Resolution: fixed.
  • Lingering Performance didn’t take into account the time left until the end of the current round. Resolution: fixed.
  • Bardic Knowledge didn’t allow the bard to make Knowledge skill checks untrained. Resolution: fixed.
  • A druid in the Shambling Mound shape with the Natural Spell feat couldn’t use any abilities or spells. Resolution: fixed.
  • Wild Shape (Smilodon) had an incorrect damage description for attacks. Resolution: fixed.
  • Wild Shape (Bear) bear had 1d4 damage on attacks instead of the intended 1d6. Resolution: fixed. Now bear attacks have 1d6 damage.
  • The monk’s Style Strike turned off after every rest. Resolution: fixed.
  • The sage sorcerer’s Arcane Bolt ability now correctly works with sneak attacks and feats affecting rays.
  • The Metakinetic Master ability no longer creates the second ability in the ability list with a wrong burn cost.
  • The slayer’s Studied Target ability used on party characters failed to end. Resolution: fixed. Now it stops working after resting.
  • Several rogue characters no longer disable each other’s Debilitating Injury spells.
  • The Mage Armor spell failed to protect from incorporeal touch attacks. Resolution: fixed. Mage Armor now provides 4 AC bonus against incorporeal touch attacks.
  • Shroud of Water and several other abilities could sometimes turn off. Resolution: fixed.
  • A magus could continue to move after a full-round attack in which Spell Combat was used. Resolution: fixed.
  • Tristian’s Angelic Form used a standard action instead of a move action. Resolution: fixed. It now spends a move action.
  • Hellfire Ray was displayed twice in the level up spell selection window for wizards and sorcerers. Resolution: fixed.
  • Freedom of Movement now correctly works on all movement-impairing effects of the Tar Pool spell.
  • True Seeing now correctly allows you to ignore different concealment effects, such as Displacement and Blur.
  • Arcane Strike worked incorrectly in turn-based mode. Resolution: fixed.
  • After you created a mercenary, some alignment-restricted spells could become unavailable even if the alignment was selected correctly. Resolution: fixed.
  • Fixed the issue due to which Peridot Wyvern became uncontrollable.
  • Fixed the issue due to which pets became uncontrollable after the companions’ duels.
  • Fixed an issue due to which ghosts couldn’t do anything.
  • The boggard’s Terrifying Croak had no Fear descriptor, that’s why bonuses to saving throws against fear were not applied. Resolution: fixed. Terrifying Croak now has the Fear descriptor.
  • The nereid’s aura was multiplied if characters succeeded at saving throws against her.
  • Mimic’s Adhesive Entanglement had no description. Resolution: fixed. Adhesive Entanglement now has the Entangle description.
  • Spectres received the halved damage from the Unholy, Positive, and Negative Energy effects. Resolution: fixed. Now Spectres receive the correct amount of damage from spells and abilities with the Unholy, Positive, and Negative Energy descriptors.
  • In turn-based mode, effects on enemies could last longer than intended; effects on any characters could last 1 turn less than intended; effects during their last active turn could be visible on the characters’ portraits but they were not visible using Inspect and on the character’s screen. Resolution: fixed.
  • Fixed the issue due to which AOE effects couldn’t be applied through doorways.
  • Fixed some errors due to which characters couldn’t hide their weapons after the battle was finished.
  • The AI behavior for a 5-ft. step in turn-based mode has been improved; freezing of AI turns in some cases has been fixed.
1 Like

Is it safe to use auto-saves and quick saves now?

They still recommend to keep 3-4 manual saves instead in other threads, so I’d say no. I keep autosaves off on my end and keep one quicksave, plus two manual saves.

Because the recent patch has not fixed it, another thing to fix:

My game regularly crashes (on PS4, patch 1.03 and before) when I am exploring the world and enter the kingdom management console (press square on PS4). As the kingdom management screen begins to load, I regularly get a blue screen crash.

Just crashed again after patch zoning from level 1 to level 2 in Amarags tomb also there was no one besides spectres and dead Barbarians . Also no pop up to report bug maybe there sick of the 7 or 8 I was filing a day


Anyway, just to confirm once again that my game crashed while I was in the Old Sycamore cave, right in the beginning of the game. I want to give Pathfinder: Kingmaker another chance when the next patch comes out, but honestly, I’m growing tired of this. I think I’m just going to delete this game of my hard drive and move on in my life. I’m not getting any refund anyway.

1 Like

Since they said that the next patch will be the one to concentrate on stability and performance, perhaps you should give it a try in a few weeks. Are playing on a regular PS4 or pro ?

I’m sure its not top priority but there’s still no music at the title screen when you 1st start

Hey I don’t know if you were trying to be funny or not but this is comedy gold lol

1 Like

I’ve been posting this solution on the threads I can see relating to this issue, but might as well post it here too.

The update broke my ability to access the menu in most areas. Completing my Varnhold Lot save and creating the “finished” file ready to import by clicking okay on the final screen seems to have resulted in the R2/L2 menu buttons not working outside of the map areas on my main file. Deleting the finished save for the DLC restored the functionality for my main character.

1 Like

Regular PS4 here. I guess I’ll wait, but yeah, I’m also losing hope.

If the issue still occurs where I can’t save because “there’s not enough space” I will lose my mind. If we can’t save how the hell are we supposed to play the game…

1 Like

Could you please add in a fast exploration mode at some point once you’re done patching most of the issues of this game? Some of us could really use an option to breeze through the maps we’ve already seen so many times but had to restart due to the bugs. And maybe a slow mode for RTWP battle mode instead of just pausing all the time?

Saddest part about your info is that the varnhold import seems to lead to a gamebreaking bug and it looks as if it might not even work as import for the main campaign. I hope both are not true on a new run cause if they are i will be seriously screwed as i deleted my pre finish varnhold save after getting my finish save. So if this is really broken i would be forced to replay varnhold dlc again too.

1 Like

Ug now I am having serious game save errors again and I only had to save games only for pathfinder . Now I am in amargs tomb or whatever it’s called and it won’t let me save at all and deleted one to have only one then trying to save and game crashed seriously thus is sooooo frustrating . I love the game but your fixes are not doing it . Also while in the tomb the second floor past the fireball and lightning traps I had to go back and forth where there is supposed to be a open wall or mechanic that open the wall it wouldn’t again to go further in the dungeon for the main storyline

1 Like

Only two saved games is what my previous post should say

Seriously??.. This is getting ridiculous :sweat:

1 Like

That hidden door has an extremely weird delay timer. After clicking it takes like 8 seconds to open for just a tiny span of time of 5 secs after which it closes again. It’s very easy to miss, i spent 30 mins just timing despite reading about it. It’s on the right side of the maze where it usually spawns fireballs and other projectiles. twice on both levers will open a hidden wall on northern part of the right side.

Considering all the bugs other then not being able to import varnhold dlc i got lucky i guess. By keeping 3 saves i got to where i was about to go to Pitax. Allthough i hear thats where it really gets scary bug and savewise. Still deleted that save and hope my newest run can import dlc.

1 Like

Well, this is moderately disappointing. I stopped playing this a couple weeks back because it wasn’t allowing me to import my Varnhold’s lot save and now having a Varnhold’s lot save will brick my menus?

I guess I’ll be waiting a little while longer.