PS4 patch-notes 01.02 - 16 September 2020

This is the full version of the patch notes. Version on the console is incomplete.

Please be aware of plot spoilers in the description below!


  • Fixed the issue due to which sometimes it was impossible to save the game.
  • Respec should work fine now.
  • Black screen after the cutscene in Varnhold’s Lot DLC was fixed.
  • Issues that led to broken saves were fixed.
  • When saving a game on PS4, you could see an error message about insufficient disk space even if there was enough space. Resolution: fixed.


  • It was possible to enter the locations that required certain companions even if you had no such companions in your party. Resolution: fixed. If you are stuck in such a location, try loading previous save.
  • There were some incorrect ways of exiting the location with the Everblooming Flower in the Other World. Resolution: fixed.
  • Zombies in Vordakai’s Tomb failed to use weapons. Resolution: fixed.
  • It was possible to start a fight with Marquise Immolatia when entering Lostlarn Keep — Upper Reaches. Resolution: fixed.
  • Dallirun Myrnas failed to summon the undead on the Flintrock Grassland. Resolution: fixed.
  • Kassil Aldori was missing on the Flintrock Grassland. Resolution: fixed.
  • You could no longer interact with Astradaemon at Vordakai’s Tomb after talking to him. Resolution: fixed.
  • Now you cannot leave Vordakai’s Tomb until you talked to Maegar Varn.
  • In the Other World area, the teleporting system was greatly improved to prevent characters from being stuck when they use teleportation spells (e.g. Dimension Door).
  • If your main character fell unconscious before your companions when you first met the Technic League, that could lead to gameplay-related issues in the area. Resolution: fixed.
  • Fixed the issues with the characters’ movement in the Stag Lord’s Fort.
  • Fixed the error due to which you could lose control over your party after Tristian’s attack at the Abandoned Keep.
  • It was impossible to enter the Valley of the Dead if Jaethal wasn’t in the party. Resolution: fixed.
  • The characters could sometimes be stuck in the throne room. Resolution: fixed.
  • Fixed the issue with the freezing of Octavia and Regongar’s scene in the tavern.
  • In Jamandi’s mansion and some other areas, weapons sometimes were hanging in the air. Resolution: fixed.
  • The main character was hanging in the air during the dialogue with Kaessi in her house. Resolution: fixed.
  • Fixed the issues with the characters’ movement in Ravaged Capital — Entrance.
  • Fixed the issue when it was impossible to exit the Abandoned Keep after you completed the Betrayer’s Flight quest.
  • Fixed the issue when Tristian was stuck at Candlemere Tower during the Betrayer’s Flight quest.
  • The algorithm that determines the point to switch between locations has been changed and should now fix the error with exiting some zones.


  • When you chose a chaotic evil option in the dialogue with Rook at the Ruined Watchtower, it was impossible to get the item necessary to solve the puzzle. Resolution: fixed.
  • Even if one of the tiefling sisters was dead, you could still ask to talk to her in the corresponding dialogue in the capital. That resulted in numerous further issues. Resolution: fixed.
  • The romance dialogue with Tristian started each time the player’s character entered the main square in the Capital. Resolution: fixed.
  • When companions joined the main character, sometimes they were not linked. Resolution: fixed.
  • Fixed the issue when it was impossible to complete the Nok-Nok and the Great Mother quest if you entered the Goblin Clearing without Nok-Nok.
  • Fredero Sinnet could die during the duel with Valerie. Resolution: fixed.
  • After the duel of Valerie and Fredero, Ekundayo’s wolf became uncontrollable. Resolution: fixed.
  • When talking to Ivar at the Lake Silverstep Village the second time, he could attack your character. Resolution: fixed.

Classes & Mechanics

  • Fixed the issues with Nereids’ aura in the game saves.
  • The alchemists could use Fast Bombs as a standard action. Resolution: fixed.
  • The kineticist’s Shroud of Water ability worked incorrectly. Resolution: fixed.
  • Frightened characters couldn’t take actions in their turn in turn-based mode. Resolution: fixed.
  • Characters with the Kinetic Blade ability were unable to attack enemies in turn-based combat if they needed to come closer to their target. Resolution: fixed.
  • Spells that have a line of effect and cone-shaped spells sometimes failed to hit the targets that were standing behind opened doors. Resolution: fixed.
  • Fixed the duration of Gather Power and other effects in turn-based mode.
  • The abilities that used a swift action each round, spent it even if they were disabled. If a swift action was spent, the prediction panel showed that a free-action ability would be used as a standard action. Resolution: fixed.
  • The kinetic knights started the game with 0 gold. Resolution: fixed.
  • The kineticist’s action panel was sometimes displayed incorrectly. Resolution: fixed.
  • When the character wielded nothing in the main hand and a weapon (or a shield with the Shield Bash feat) in the off-hand, the iterative attacks with the off-hand weapon didn’t occur. Resolution: fixed.
  • Resurrection and Raise Dead sometimes failed to work. Resolution: fixed.
  • Locket of Magic Missile Mastery didn’t work on the Force Missile ability. Resolution: fixed.
  • Confusion didn’t have any effect on enemies. Resolution: fixed.
  • Bardic Performance failed to switch to a new song as fast as it should. Resolution: fixed.
  • Lingering Performance allowed the character to gain benefits from multiple songs at the same time. Resolution: fixed.
  • Sensei Advice: Diamond Soul didn’t work. Resolution: fixed.
  • Draconic Mettle, which belongs to the monk’s Scaled Fist archetype, had no bonuses against fear effects. Resolution: fixed.
  • Some Blindness effects lacked descriptions. Resolution: fixed.
  • Weapon enhancements of magi and paladins had no visual effect on characters. Resolution: fixed. Now the weapon enhancement duration is shown with a special effect.
  • The Wild Energies spell failure chance was affecting potions. Resolution: fixed. Potions are now safe to use.
  • Nereids’ Beguiling Aura failed to provide immunity for 24 hours after a successful save. Resolution: fixed.
  • Charges from quivers were spent at a double rate. Resolution: fixed.


  • Fixed the Necklace of Double Crosses.

User Interfaces

  • Now the effect duration is displayed in rounds in turn-based combat.
  • The page for the Illusion school of magic was empty. Resolution: fixed.
  • Unessential messages are no longer displayed in the combat log during cutscenes at the House at the Edge of Time.
  • Some converted spells were incorrectly displayed on the spell panel. Resolution: fixed.
  • In some cases, hints in the Equipment and Inventory windows were displayed incorrectly. Resolution: fixed.
  • Fixed the issue when Amiri’s fourth weapon slot was locked after Armag broke her sword.
  • Now you can change the order of characters in your group


  • The number of available quicksaves and autosaves was set to 1.
  • Some combat log notifications about spell immunity have been localized.
  • Fixed the issues when the AI missed the turns, especially at low FPS.
  • In the Stag Lord’s Fort, if the enemy ran to ring the bell, the enemy’s turn couldn’t end in turn-based mode.
  • Full-round spells weren’t applied during the current turn if they were targeted outside their range, within a 5-foot step.
  • The character’s movement stopped before it should when the camera was centered on the active character and in some other cases.
  • Irrelevant messages were displayed in the log on mouse-hover over a trap by a character with a low Trickery skill level.
  • Fixed the character’s movement in the throne room when seated.
  • An animal companion wouldn’t get up after it fell in combat. Resolution: fixed.
  • Fixed the issue with game freezing when saving.
  • An error during an attempt to save the game could corrupt the previous save. Resolution: fixed. Now the saving error does not affect the previous game save.
  • When saving a game on PS4, you could see an error message about insufficient disk space even if there was enough space. Resolution: fixed.

thanks you very much for your speed to resolve these bugs ( i am french my english is not good sorry :laughing: )

Though I find your solution to set quick and auto saves to 1 not very commendable, I sure do hope corrupted saves are a thing of the past. I’ll rotate 3 tmp saves as my own version of quick saves. If that leads to save problems, I’m done with the game… fingers crossed!

(also very curious how you handle quick and auto saves in excess of the new number 1)

We can still select multiple auto and quicksaves. Will that lead to corrupted saves?

Playing half an hour, and yes, the dreaded i cannot save, you must delete blah blah blah…
Totally fed up with this incompetence :rage:

Happened on creating a new manual save…

Edit, and on the next area transit the autosave fails with the same … after checking, the autosave is not overwritten. On loading i get the previous autosave location/state

1 Like

is there any notice about bugs still here after this patch?

I believe that these are just the patch notes for the next patch that still needs to go through the approval process that is required by consoles. It’s possible that this patch won’t be active for a couple of weeks still. Just the unfortunate nature of submitting patches on console.

Ehm no? The patch is of today , as i also saw on my ps4 that it was installing. So, let s hope for the best

This is for todays patch and I can confirm that Varhold scene is fixed! was hoping to have music at the title screen now but obviously there are more important things, good job!

I read somewhere on this forum that save issue is still there? What about respec instead?

Could you please tell me what did you do? You’ve increased the number of auto-saves? And what was your total number of save slots when you started getting the error?

1 Like

Surely the save bugs must have been fixed?

Doesn’t look like it tbh

It proceeds to freeze/crash, just mere moments later, when the DLC ends, making the DLC still incompleteable, unfortunately.

1 Like

I deleted all saves, quick and manual, but the one with my latest progress. Will see how that goes and report here. But I am not optimistic and will have little time to play coming days …

@mofoless no. I got the save errors after installing today’s new patch …

I have not had a save error today, but I have also learned to leave the “game log” open, and after I hit “Quick Save”, I do not do anything until the quick save is complete. I have my saves set to 1 auto-save (as the default) and 5 Quick Saves.

I am still having memory-leak type issues and the game gets slower and slower till it crashes.

Give it 10 hours or so and you’ll see


I have been playing on/off for about 12 hours.

I have only a advanced a few rooms, will update if I get the error, are people getting errors the exception? did it fix anything for anybody?

Respec works now. Haven’t played long enough to find out if saving is fixed