Crash at the Old Sycamore

Platform: PC, GOG.

Do you have any mods? No.

Please explain the issue is in as much detail as possible:
When entering the Old Sycamore with my party (Main PC, Harrim, Valerie, Ekundayo and Jaethal) I had this crash, that continues to happen every time I try to enter the area. I’ve tried reloading a previous save but nothing changed. Thanks for the help!

Try verify / repair the game files.

If that didn’t work, try to launch the game as Administrator.

Do you have any mods installed?

Need 20 characters

I tried them both but the crash is still occurring.

None, I’ve been playing vanilla.

I have a similar problem, same conditions. Running GOG version on Linux.
Entering Old Sycamore for Jaethal companion quest kicks me out of the game.

Here’s hoping they fix it soon.

Sorry man. I wish I could help you figure it out. I’ve been blessed with a largely bug-free experience with 600+ hours and several playthroughs, with the exception of my first playthrough at launch. I guess it’s just a luck of the draw kinda thing.

Thanks for the help, yeah unfortuantly bugs depend a lot on chance. But I’ve been playing since launch and I’ve seen all the work that Owlcat put in to squash most of the bugs, some still crop up but PF:K is still an awesome cRPG worth replaying.

I can confirm the same bug - I get the exact same error under similar circumstances: entering Old Sycamore for Jaethal’s quest. I’m also playing in Linux (Debian Buster), but via Steam. Btw, I’m playing the vanilla game: no mods, no cheating.

I tried verifying the game files - as recommended - but to no avail: the crash keeps repeating itself.

It really seems like a wider Linux-version bug?

I have the same crash issue trying to complete Jaethal’s quest line running on the latest linux steam build.

I wonder if there’s a way to directly modify the save to fix this?

As a follow up, I ended up using the Cheat Menu mod to bypass the Old Sycamore section of the quest.

Same problem in same place, but I can’t solve it. 2.5.1d.