CPU thread optimisation

This is a HWMonitor reading for PF wrath of the righteous.

This is a reading for Cyberpunk 2077

You would notice the steady and hard workload for CP77. You would also notice the uneven and harder strain on PF.

This would cause my CPU fan to work at the speed of the bottleneck. Which would be the hottest thread on my CPU.

I can’t play this, it’s not safe for my hardware.

1 Like

Good thinking. Thanks for the warning.
Any ideas on why it won’t work reasonably distributed? Windows should always try to distribute threads. Maybe not as optimized as project red, but at least better than this.


I’m not that kind of computer wizard.

I noticed the fan spin up more than average. Then i checked around for the heat distribution, and found this.

I’m able to play on windowed 1366*789 and capped at 60hz. But it’s just not the same.

Hope it helps.

UserBenchmarks: Game 126%, Desk 90%, Work 148%
CPU: AMD Ryzen 9 3900X - 83.4%
GPU: Nvidia RTX 3070 - 149.2%
SSD: Samsung 870 EVO 1TB - 120.3%
RAM: Unknown 3200 C16 Series 2x8GB - 100.3%

1 Like

Is it possible that much higher FPS or other graphical strains might explain the difference in CPU stats (i.e. I presume a hard working GPU does affect and interact with CPU).

Personally, with today’s patch, I noticed my FPS was uncapped when the game was loading (i.e. around 1300 FPS). It was my bad, in the sense that I normally cap FPS by default for all software and games (did so afterwards for WotR in the GPU control panel). So your post reminded me of that issue I noticed today.

I’m pretty sure v-sync has always been on. V-sync would match the game’s refresh rate to my maximum monitor’s fps. Also, it’s always like that, the game. V-sync only comes off when the settings are set to low.

There would be a number of threads on various subject on the distributor’s platform, Steam. I would suggest dropping by sometimes.

Sorry for my broken English, it’s early.

I think that would be something one would toss at Unity’s desk.

CPU use :: Pathfinder: Wrath of the Righteous General Discussions (steamcommunity.com)

I’m not sure i got the link right. It has someone who actually knows about these things.

I think it’s called multi-thread optimisation.

Multithreading (computer architecture) - Wikipedia

Something i think may be relevant.

I turned v-sync off in the settings on purpose.
But then cap FPS in the GPU control panel.

Anyhow, it answers the question : it was not your issue it would seem. I say seem, because v-sync can falter when a game is loading, etc.

It’s the CPU, not the GPU.

The multithreading is… not optimal. There are cores at 90% use and others at 30% at the same time. The CPU heats up to the value of the strongest strain. Unless i can configure multithreading on Windows, there’s nothing i can do about it.

What i am actually doing about it is run the case open. I don’t have enough case fans as i could. The motherboard layout doesn’t help. The CPU fan is good enough to handle the heat with enough ventilation.

I did try to force V-Sync on Nividia control panel. And enabling triple buffering and capping the FPS at 48 and running in a 1366*789 windowed game. Didn’t help.

Someone on Steam’s forums commented “Welcome to Unity”.

1 Like