Console patchnotes: PS4 1.04, Xbox

Console patch-notes: PS4 1.04, Xbox

Please be aware of plot spoilers in the description below!


  • The game’s stability was improved, and it should crash less likely or not crash at all on the later versions of consoles.*
  • Fixed (hopefully!) an error message about insufficient disk space incorrectly displayed on PS4.
  • Fixed the Varnhold’s Lot DLC final save issue, now it can be imported correctly and no longer breaks the game’s interface.
  • The performance of item-related (inventory, vendors, loot) UI elements has been improved.
  • General performance has been improved, especially, when using a large number of long-lasting AoE effects (auras, Cloud Kill and so on).
  • Race feats weren’t displayed in the class progression. Resolution: fixed.
  • If your kingdom was destroyed, you couldn’t view the last event and change the automated kingdom management settings. Resolution: fixed.
  • The battle with Armag cutscene was sometimes triggered incorrectly at Flintrock Grassland. Resolution: fixed.
  • In turn-based mode, when spells with the ultimate range were used, prediction sometimes showed that the spell would be applied but then the spell failed because the character did not have enough time. Resolution: fixed.


  • Fixed the issue with sudden companions’ deaths because of the curse at the Camp at the Capital Gates.
  • Fixed the untimely start of the dialogue in Sorrowflow.
  • Fixed the issue due to which you could make Mobility checks at the Castle of Knives only once.
  • Fixed the issue when characters could sometimes be stuck on the second floor of the Capital Inn.


  • Fixed the issue, which made it impossible to complete A Bard’s Calling quest if several conditions weren’t met at Rushlight Fields.

Turn-Based Mode

  • The summoned creatures failed to disappear immediately after they died in turn-based mode. Resolution: fixed.
  • Turn-based combat could fail to end even after all the enemies were dead if an uncontrolled friendly character attacked a dead enemy. Resolution: fixed.
  • If a character started the turn-based combat with a full attack, the Initiative roll wasn’t made until all the hits were finished, which resulted in the incorrect calculation of the flat-footed effect. Resolution: fixed.
  • Characters that did not act in the surprise round were no longer flat-footed at the start of the first normal round, but according to rules, that condition should have remained until the characters’ turn. Resolution: fixed.
  • You could order more than one character to perform Charge or some other aggressive action before starting the battle in turn-based mode, which caused the game to freeze or the turn to be skipped automatically. Resolution: fixed.
  • Detecting a trap or some other hidden object could interrupt Charge in turn-based mode, which could cause the turn to freeze in some cases. Resolution: fixed.
  • In turn-based mode, if a monk switched between combat styles, the new style wasn’t applied until the next turn. Resolution: fixed. Now the new style is applied immediately if the monk has not already used his attack in the current turn.
  • In turn-based mode, it was impossible to hide the weapon set selection window or take a turn after changing the weapon. Resolution: fixed.


  • Several druids complained that they couldn’t find any ordinary quarterstaffs to buy. Resolution: a new consignment of quarterstaffs is going to be delivered to traders.
  • Amulet of Mighty Fists did not give any benefits to overcoming DR /magic and incorporeal immunities. Resolution: fixed.
  • When equipped by a monk, additional attacks granted by the Steelwind sai sometimes failed to stack stacking with additional attacks from Haste. Resolution: fixed.
  • Storyteller failed to take all your parts of the Ring of Reckless Courage when creating the artifact. Resolution: fixed.
  • The description of potions incorrectly stated that using them took the same action as using a spell. It should have stated that potions use a move action. Resolution: fixed.
  • Using spells provided by items caused the character to cast defensively provoked attacks of opportunity. Among such items, only scrolls should be cast defensively and cause the attack of opportunity on a failed defensive check. Resolution: fixed.
  • Metakinesis cost and effect are now correctly applied to kinetic blades.

Classes & Mechanics

  • The effects that should have disappeared after the battle failed to dispel. Resolution: fixed.
  • Permanent effects from auras bound to a point or an NPC that affected your characters (for example, Guarded Hearth), disappeared after you restarted the game. Resolution: fixed.
  • Prediction failed to work when aiming at characters’ portraits. Resolution: fixed.
  • Base Attack Bonus (BAB) of ranged and melee attacks was sometimes calculated incorrectly on the character’s page. Resolution: fixed.
  • The duelist’s Parry ability did not work properly and had an incorrect description. Resolution: fixed. The ability now works correctly and does not reduce the number of attacks per round.
  • If a spell cast by a magus with Spell Combat on was interrupted (for example, due to a failed Concentration check), it was impossible to make an attack according to Spell Combat rules after that. Resolution: fixed.
  • Smart cursor failed to suggest that a magus make a full or normal attack by default if the magus had a charged spell and Spell Strike was on. Resolution: fixed.
  • The druid’s pets had no bonus against trip maneuvers. They should have had a bonus from the number of legs. A centipede also had no immunity to trip. Resolution: fixed.
  • The description of the ranger’s Archery Style incorrectly stated that it granted pinpoint targeting (instead of Improved Critical it actually provided). Resolution: fixed.
  • The bard’s song stopped immediately without Lingering Performance. Resolution: fixed. Now it is active until the end of the round.
  • Singing Steel Breastplate failed to speed up switching the bard’s songs on. Resolution: fixed.
  • The Endurance feat only granted the ability to sleep in medium and heavy armor and did not give other bonuses. Resolution: fixed.
  • Fixed the description of the Vital Strike feats.
  • Heroic Invocation made the characters fatigued after the effect ended. Resolution: fixed.
  • Blind Fight now correctly makes your character not considered flat-footed against melee attacks.
  • Corrupting Touch ignored bonuses to AC that affected other touch attacks of incorporeal creatures. Resolution: fixed.
  • Acrobatic Movement, Treat Affliction, and Demoralize sometimes were not available to characters. Resolution: fixed.
  • Using Acrobatic Movement to avoid attacks of opportunity slowed the character more than intended. Resolution: fixed.
  • Stone Fist was resolving attacks against touch AC instead of normal AC. Resolution: fixed.
  • Holy Sword’s enhancement bonus stacked with all other enhancement bonuses. Resolution: fixed.
  • The Slowed effect failed to affect the characters out of combat if the control type was set to controller Resolution: fixed.
  • Several damage-increasing effects were incorrectly increased by abilities granting a bonus to damage, such as Smite Evil. Resolution: fixed.
  • The effects, which are normally applied to all the characters at the location, stopped working. Resolution: fixed.
  • Vordakai’s Fear Aura ability now correctly works with Remove Fear and other effects against fear.
  • Lethal Stance gave a bonus to attack with unspecified type, thus stacking with everything, although its description stated that it should give competence bonus. Resolution: fixed.
  • Ghosts and Bloody Bones Beasts had a higher reflex bonus than intended. Resolution: fixed.

User Interface

  • If a character leveled up during the battle, the corresponding notification was not displayed on characters. Resolution: fixed.
  • Fixed how the BAB and Saving Throw values, as well as the Spell Table, are displayed in the Class Progression window.
  • In the Unfair mode, the real skill check didn’t always match the log entry. Resolution: fixed.
  • Immunity to effects was not displayed in the combat log. Resolution: fixed. Now, if the target is immune to an effect, a corresponding message is displayed in the combat log.
  • Effects and conditions were displayed on enemies right away but a successful Knowledge (Arcana) skill check caused this data block to hide. Resolution: fixed.
  • If you closed the inventory when rotating the character’s model, it was impossible to interact with the items after you re-opened the window. Resolution: fixed.


  • Fixed the incorrect description of the tiefling race in Russian.
  • Fixed the incorrect ending in the dialogue with Fes Aldragem.
  • The battle music failed to start. Resolution: fixed.

*Additional note: in order to improve the game’s stability, we had to increase the saving process time. Now the game-saving process might take quite some time at the later stages of the game. It was a necessary measure to reduce the probability of the game crashing and your progress being lost.

1 Like

Since the patch, I redownloaded my completed Varnhold’s Lot file to try to import it into the maingame, since I had deleted it to be able to play through Chapter 3. When I loaded up my main file, there was no Import dialogue box. So I checked, and even though the file is saved to my system, it does not show up under the Varnhold’s Lot’s Character folder in the game menus. So I tried to recomplete the DLC with a save just beforehand. It saves just fine, but then the file still does not show up under the character folder like it used to, and I still am not getting the Import prompt in my maingame. Tried deleting all completed save files in my PS4 system, did it again, still no dice. I’m worried that deleting it and redownloading it has permanently impacted this character’s ability to import into my main game. :C

Still no fixes for game crashes in Pitax castle? This game came out on Aug. 17 (I pre ordered it). For the past month, I haven’t been able to play it because it’s so shitty I can’t save. It crashes on save everytime I try to save. Who do I need to talk to get a refund? Other games coming out soon I’d rather play. Apparently I’m the only one having problems in Pitax castle.

At which point are you in the main campaign?
Final save actually shouldn’t show up in the game’s interface, I think it was a bug that it did before. Maybe you haven’t gotten to the part where you are supposed to get the import screen?

I’m in Chapter 4. I assisted Restov with the barbarian invasion, then went and took care of The Betrayer’s Flight while I wait for my scouts to find Armag’s Tomb. I believe the Import should be available anytime between the Start of Chapter 3 and the end of Chapter 4, no?

Yeah, it should. Could you send me your Final save, your main game save, and we’ll take a look?

Here you are! It should be noted that I am on the World Map. Does the screen only come up when my character is loaded into a map? … I am suddenly remembering how the trigger menus did work on the world map with the bug, so maybe I’m just an idiot and should have gone into an area to get my import…

Could you enter any location and check if the import screen appears?

Another bug (annoying this one) has popped since the last patch : there’s not anymore collision detection, so i can ran into anybody without being stopped. I’m on xbox one X and it’s happening everywhere.

Ok so my final save that dissapeared might actually still be there. So is there any way to know for sure other than import moment?

I think if you are on PS4 you can check how your save files look on your hard drive, I’m not sure if you can see your save files on Xbox though, they seem to be in the cloud.

1 Like

Ok thnx fir quick reply, on xbox so can’t see the actual files. Well guess i’ll progress main a lil instead of finishing the re dlc run, which btw was running a lot smoother without crashes this time.

Whoever you bought it from, generally speaking. Most likely XBOX or PlayStation support in this case, unless it’s a physical copy (was there even one?) in which case it would be the store where you actually purchased it.

“The game’s stability was improved, and it should crash less likely or not crash at all on the later versions of consoles.*” - translates to slowdowns are more likely to occur and save takes longer now, stability not improved.

“Fixed (hopefully!) an error message about insufficient disk space incorrectly displayed on PS4.” - haha nope. Maybe instead of trying to fix an error message you should fix the error itself :stuck_out_tongue:

Seriously guys, this is just pathetic now. If you want to release a console version, make sure it works, community can’t mod and fix your game for you on consoles like they can do on pc.


The import screen did indeed come up just fine in an area, so my bad for jumping the gun. It’s because I could see the save in-game beforehand that I thought it wasn’t working. Sorry again for adding fuel to certain people’s fires when there was no cause.

1 Like

Character movement is still being interrupted and causing PC’s to lose their action.
Cursor ‘attack’ function no longer triggering all party members to attack. Seems to just pick whoever it wants and only that character attacks.
Cursor function still randomly disappearing from command menu.
Could just be me but characters seem to be fatiguing quicker than intended. I can barely travel a day without the party becoming exhausted, this even happened on the initial world map move from Restov to Olegs.
Stealth is broken as hell unless intended to function this way, ie; any character stealthed prior to combat is automatically removed from stealth when combat is triggered. I don’t see why it would be intended to function this way though.
Also sneaking past anything seems nearly impossible even with high stealth making stealth essentially useless in any form.

1 Like

Also still encountering the issue where I’m getting locked out of combat and have to go into the menu and back out again to progress.

So did anyone else get a weird bug where male characters get referred to as females? Currently in the Varnhold vanishing chapter playing a male dwarf yet a couple of times I’ve been referred to as a female in the text.


I confirm…my human male rogue is suddenly become a female in the text.