All the current workarounds for Save Files issues

Not enough space for save files

Unfortunately, it’s not a bug. Game consoles have limitations on the maximum amount of space that one game can occupy with its save files. Our game is complex and was developed for PC at first. Each of our save files contains information about your progress, decisions, and the state of the world. So the further you go with the game - the heavier your saves become. Thus, if you tend to make lots of manual save files during your progress, you will inevitably reach the allocated space limit at some point.

It would be fair to say that the optimal amount of manual saves you can keep to avoid pop-up warnings is about 3 or 4 for Xbox and up to 7 on PS4. We’re currently developing a solution to make those limitations less inconvenient for our players. Still, the only solution it might be is the limited save slots, since we can’t do anything about console restrictions.

Corrupted saves and loading issues.

Corrupted save files issue should be mostly fixed in the previous patch. If you still experience troubles while saving the game, or loading your saved game or random issues appearing after loading - it might happen because some of the save files (stored in the cache or in the main storage) were corrupted in the previous version of the game. Please try to clear your console cache and delete old save files.

How to clean your console cache


  • Turn off your PlayStation 4. Do not enter Rest Mode.
  • Once the indicator light on top of your PlayStation 4 is off and has stopped blinking, unplug the power cord from the back of your console.
  • Wait at least 30 seconds.
  • Plug the power cord back into your PlayStation 4 and turn it on.


  • Turn off your Xbox One.
  • Once the indicator lights on the front of the Xbox One and the console’s power brick are off, unplug the power brick from the back of your console.
  • Wait at least 30 seconds.
  • Plug the power brick back into your Xbox One and turn it on.

How to delete save files

It would be better to delete all old save files directly from the game, for example, after having an autosave or if you were able to create a 100% working save file. Load your backup save and make sure everything is good, and it’s not corrupted. Delete all your manual save files (except your current one), and quicksave files. Create a manual save file and make sure it works fine and is not corrupted.

If all your save files are corrupted and you just want to start a new game:


  • Open the Settings menu at the top of the dashboard.
  • Select Storage, then select System Storage.
  • Select Saved Data.
  • Choose a game to access the game’s saved data.
  • Press the Options button and select Delete.
  • Choose the saved data files to delete, then select Delete.


  • From Xbox Home, go to Settings.
  • Go to System and select Storage.
  • Select Manage storage on the right-hand side of the screen, then select View contents.
  • Highlight a game, press the Menu button, and select Manage game.
  • Select Saved data on the left-hand side of the screen.
  • Choose a game to access the game’s saved data.
  • From here, use the Options Menu to delete files or to view more information about a specific file.
1 Like

I have a few questions, first and foremost i would inquire as to why is less than 200mb of save space beyond the maximum when games like BF4, and CIV6 have save games over 1 to 4 GB of space??

You are in no way reaching the maximum save space, nor is it save space full. Before the patch i had well over 12+ saves on 2 separate characters. The issue has to be a replicating chain of corrupt info in the save. An item or switch that keeps failing and relogging during the save process. So anyone prepatch has had well over 140mb of the “maximum save space” that your claiming.

Checking PS4’s storage info, you could easily allocate extra space for the save info considering they have a 5 GB max per unload for each game. It has to be something on your end and it surely isnt “the sheer expansiveness” of this game. This may be as easy as contacting Sony and seeing if you have a smaller maximum save space than most if not all other games on its platform.

It shouldn’t be 200 MB save space in total. As far as we know (and it was confirmed by Sony), the allowed space is 1GB. It’s less for Xbox. If you have corrupted save files, please try to clear the cache and delete your old save files.

Regarding the saves pre-patch, it might be because of two reasons:

  1. You were at the earlier stages of the game. As I said, the size of the save files increases drastically further in the game. While one save file might be around 20 MB at the early stages of the game, it would be 100+ at the latest stages.
  2. You haven’t received a warning about the allocated space for the saves, but instead, your save files were merging one with another, creating corrupted files.

We have some reports about a warning message appearing even when the limit of 1GB hasn’t been reached. We couldn’t reproduce it at our side, so any additional information about the issue (including a screenshot of the System Storage with the amount of space that is currently occupied by Pathfinder save files), for example if you tried to clear the cache and were your saves corrupted before, would be incredibly useful for our team to find the source of the issue.

I got the “no space to save” error consistently when using Auto-saves and Quick-saves with less then 250mb of total save file space used for the game. I never got close to 1gb of save files before the saves would become corrupted.

I also can’t save on PS4 anymore. I deleted almost any savegame, now there is only one from the Main Game and one from Varnhold’s Lot left and I still can’t save. No Quick Save, no Auto Save. PS4 says that I have 66,25 MB of save files for Pathfinder: Kingmaker.

Never had any corrupt save files though. Oh, and I uploaded some savegames to the ps4 online storage. Never checked if these files count as well.

Is the optimal amount of save files meant to be 3-4/7 per game character (meaning everytime you start a new game, you should have a certain amount of save files) or for the whole game? - the latter would definitely a big problem.

In anyway… It should somehow be communicated to players about this recommendation that aren’t aware of this forum otherwise they keep saving and end up having the same issues. Maybe via an info box in the game if that is possible?

Maybe you should reach out to Obsidian - they used the same game engine for Pillars of Eternity 1&2 and ran into similar problems with the second game on console, including save game issues. Might be a coincidence but maybe these things are related? Just a thought.

1 Like

Ok, so then can someone explain how I have 0 saves ( I deleted all previous saves) and it still says I’m 5.4MB short? When I have around 800GB free?

1 Like

Can’t save the game anymore because there’s no more space available (in the game’s opinion), therefore I can’t play the game anymore. Sorry about my luck, I guess. This is on Xbox One.

Only ever kept three manual saves and finally whittled that down to two save filed just to be able to progress. Not EVER gonna keep just one save file because saves will inevitably become corrupted and get deleted for no reason. You NEED a backup save just to play this game with some assurance that you won’t lose your progress. Tried the workarounds given on the forums and still SOUL on being able to save.

There’s a million more bugs, frame rate issues, random crashes, etc., that others have reported as well as just problems with how unbalanced the actual battle system for the game is (don’t get me started on the cyclopses and soul eaters in Vordakai’s tomb) that destroy the otherwise interesting and fun experience of the actual story.

Fooled me once, Owlcat. That’s shame on me for spending the full amount for the console release. But shame on you for calling a game this broken the “definitive” anything. Everyone who asks for their money back should be refunded.

Could it be a cache problem with the ps4?

Here is why I’m asking.

Right now, I only have three savegames. One from Varnhold’s Lot, one Auto Save and one regular save (both main game) and I ran into the save space error although I only had about 67 mb of savegames. I then did the following:

  • removed most savegames from online storage
  • deleted a lot of old save files from other games (mostly beta and demo stuff)
  • turned off the PS4 and unplugged it for a couple of minutes

I resumed my game and played the whole Valley of the Dead Dungeon (which was f…ing amazing) and I saved a lot manually, overwriting the same savegame again and again. When I finished the dungeon, I travelled to Maegar Varns City, sold all my stuff there, tried to save… and ran into the savegame error again. It said that about 30 mb of additional space was needed. Lucky me, the auto save before entering the City worked. I quit the game, powered off the console and unplugged it over night.

Today I resumed playing and guess what? I was able to save again.

Maybe this helps to identify the problem.

It doesn’t make sense deleting saves as you keep playing and deleting you will eventually have space for only 1 save theres really no point in playing ATM

Pillars 2 doesn’t have any serious save issues at all though. I can and have had over 18 save files at once on 3 or 4 characters. Here i can only have about 4 or 5 total once i get far. Pillars 2 has loading speed issues sure but save space is new for me and i have spent a couple of weeks real time in that game with no super serious issues besides occasional crash at big text script snd slow loads.

1 Like

It wasn’t the main issue for Pillars 2, those were crashes even freezes that forced people to unplug their consoles while still on, true. However I also noticed people complaining a lot about corrupt save games and alike - not such a “limitation” of save games, but save game issues nonetheless. Since both games use the same engine it is possible that for both these problems have the same source, yet are also different because the games obviously have their differences.
Nevertheless both games were just recently released on console and had massive problems , it wouldn’t hurt to ask.

So the “not enough space to save” is not a bug? I just completed the Rushlight tournament, have only one save on Xbox One and still get this message when I try to save it. It was a fun game despite the issues, I lost my first game around the same spot I am currently stuck on due to save corruption, and now I am stuck with a single save that is too big for Xbox to handle. Should I just forget about it and move on or is there hope that I will be able to continue playing at some point?

Yes and no. There are limits for saves on consoles, but there is also a bug which apparently has something to do with how game is calculating the size of the next save when you are trying to make one. The game sort of needs to check if you have enough space to save, to avoid save corruption. This system apparently starts glitching after you’ve been playing for some time and guesses the size of the next save incorrectly and gives you the message that there’s not enough space. It should get fixed by the next patch, but for now looks like it’s better to have 2-3 extra saves you could delete when you get a message like that, without deleting your last save where your progress is saved. Then you should make a new save and exit the game for a couple of minutes. After that you should be able to save again, because that glitch will go away after restarting the game.
If you only have one save, please don’t try to delete it, it’s risky. You may not be able to make a new one because of this bug. If you are not in the hurry, you could wait for the patch, by our estimates it should come out next week. And after the patch you should be able to have at least 7 saves on Xbox. Maybe more if it’s in DLCs or early chapters.

1 Like

Hi Owlcat Games,

The Delete Files instructions does not work for an XBOX ONE-X. Do you know how to do this on this next generation XBOX device?

This, of course, is not to be confused with the yet to be released XBOX X Series.



this might be a graphical bug that will never be fixed. i have noticed on ps4pro that when you delete a save file, while in the game, the icons don’t delete, but it will corrupt the save file (just the one you’re attempting to delete). the only way to actually delete a save file is from the main menu with no save files running.

You can delete saves from the main game menu, it should still help. Also, based on the information above, we can assume that it’s the cache issue. So if you are absolutely sure that your saves are less then 512 MB and you have “not enough space” issue, you might try to reboot your console or to clear the cache.

1 Like

This is weird, it shouldn’t be like that and it’s the first time I hear about saves behaving like that. How many saves do you currently have?

Hi Siri, Since last patch on xbox one x, my character can run through other characters, just like they were ghosts. Collision detection turned off at least. Do you work on this ? Thank you for your hardwork !